Unpopular opinion: i64, int64_t, Int64 and similar types should be named according to their actual meaning, Ring64.
Even better, all programming languages should have a Ring[N] type that provides unit, zero addition and multiplication over a domain of N-bit strings, with the compiler applying proper optimizations when available (and requested).
The endianness and the sign bit are implementation details: the point of my insight (which could be wrong, btw) is that the working of fixed width integer types is that of a ring of bit sequences of such widyh, not that of N or Z (that's what people would expect from something called "integer").